loetstelle.net
Lötstelle Userforum
 
 FAQFAQ   SuchenSuchen   MitgliederlisteMitgliederliste   BenutzergruppenBenutzergruppen   RegistrierenRegistrieren 
 ProfilProfil   Einloggen, um private Nachrichten zu lesenEinloggen, um private Nachrichten zu lesen   LoginLogin 

LCD-Display(4x20,HD44780) zeigt nach Umstellen auf externen

 
Neues Thema eröffnen   Neue Antwort erstellen    loetstelle.net Foren-Übersicht -> Mikrocontroller
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Nixus1



Anmeldungsdatum: 27.07.2012
Beiträge: 1

BeitragVerfasst am: Do 30.Aug 2012 14:14:19    Titel: LCD-Display(4x20,HD44780) zeigt nach Umstellen auf externen Bauteile finden Antworten mit Zitat

Hallo Leute,
mein LCD-Display(4x20,HD44780)funktioniert bei Verwendung des internen
1MHz-Takt am ATMega16 korrekt. Nach Umstellen auf externen Quarz(16MHz)
zeigt das Display nur noch Hieroglyphen an, selbst wenn der F_CPU-Wert
in der lcd.h-Datei auf 1000000 geändert wird, genauso ist es bei anderen
Werten, z.B. 8000000. Nach Rückstellen auf den internen Controllertakt
funktioniert alles wieder korrekt. Was kann die Ursache sein??
Vielen Dank für die Hilfe im Voraus!!
Walter
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
loetadmin
Site Admin


Anmeldungsdatum: 31.12.2004
Beiträge: 1022

BeitragVerfasst am: Do 30.Aug 2012 15:49:56    Titel: Bauteile finden Antworten mit Zitat

Ohne nähere Angaben zur Verwendeten Library und Umgebung etc kann man nur wenig sagen.

Vielleicht wurde die Quarzfrequenz schon an anderer schonmal Stelle definiert ?
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden
dolf_66



Anmeldungsdatum: 28.08.2011
Beiträge: 114

BeitragVerfasst am: So 02.Sep 2012 05:55:19    Titel: Bauteile finden Antworten mit Zitat

am 44780 gibt´s nen widerstand zum frequenzeinstellen.
üblicherweise ist das n 91k / 100k widerstand (smd 913 / 104).
gibt auch display´s die mit 200k ausgerüstet sind .
dann widerstand ändern.
kann auch sein das der displaycontroller nur compatibel ist ....
steht 44780 auf dem chip?
ansonsten mal in der software nachsehen ob es da timingprobleme gibt.
mfg
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Anzeige






Verfasst am: Heute 09:53:24    Titel: Bauteile finden

Nach oben
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    loetstelle.net Foren-Übersicht -> Mikrocontroller Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum nicht herunterladen


Powered by phpBB 2.x © 2001, 2002 phpBB Group

Sie sind Besucher Nr. 1199334
©opyright by Markus Vohburger 2005 All Rights reserved