Anzeige:

Probleme mit Optokopplerschaltung

Hier finden sie die archivierten Beiträge des alten PHPBB Forums von www.loetstelle.net

Probleme mit Optokopplerschaltung

Von Caro am 14.06.2005 18:09

Habe immer wieder Probleme mit einer leider nicht selbst ausgelegten Schaltung zur Erzeugung von kurzen (microsekunden) aber recht starken (bis 100 V und 3A) Strompulsen (kHz Wiederholfrequenz).
Dafuer wird ein Signalgenerator (Rechtecksignal, 10-40 microsek. Pulse, 3 Volt Max.spannung, 47 Ohm Widerstand zwischen Kathode und Siganlgenerator) ueber einen Optokoppler (CNY27F) mit einem Schalttransistor (TIP162) verbunden.
- Kollektor Optokoppler (OK) nach Datenblatt ueber 75 Ohm Widerstand an Versorgungsspannung (VS+)
- Emitter des OK an Basis des Transistors
- Emitter des Transistors an Masse der VS und Masse der Starkstromquelle
- Kollektor des Transistors ueber Verbraucher (Widerstand) an Starklstromquelle


Leider schaltet mein Transistor dauerhaft durch und ich erhalte kein gepulstes Signal.
Wo koennte grundsaetzlich die Schwachstelle bei der Schaltung liegen? Muss ich mir bei den kurzen Pulsen grosse Gedanken ueber den Widerstand des Verbrauchers machen?

Besser noch:
Kann ich eine aehnliche Schaltung auch ohne Optokoopler betreiben? Moeglichst ganz einfach nur mit Transistor und Widerstaenden? Wie muss ich da den Siganlgenerator und die Starkstromquelle mit dem Transistor verbinden? Wo finde ich eine Schaltung fuer einen aehnlichen Zweck?

Von dunkelmann am 14.06.2005 18:35

Es dürfte vom Emitter des Optokoppklers keine Verbindung nach Masse geben, sonst kann kein Basisstrom fliessen. (ich gehe davon aus, dass die Massen verbunden sind)
Wenn der Transistor trotzdem leitet, ist er entweder defekt oder falsch angeschlossen.

Wenn es deiner Schaltung nichts ausmacht, dass die Masseleitung geschaltet wird, reicht auch ein einfacher Transistor mit Basisvorwiderstand oder ein Mosfet, wenn die Signalquelle stark genug ist

Von Krypton am 14.06.2005 23:55

Hi!

Wie Dunkelmann schon schrieb, hast du ja nen Kurzschluß von Optokoppler-Emitter nach Masse.

Hab mal geschaut wegen deinem TIP 162 (dachte vielleicht ists ein PNP, wegen Dauer-Durchschalten).

Da es aber eh ein NPN ist, würde ich auch raten, noch mal die Anschlüsse zu überprüfen.


Hier mal das Datenblatt zum TIP 162
http://www.alldatasheet.com/datasheet-pdf/pdf/MOSPEC/TIP162.html

Cookies musst auf der obigen Page zulassen, sonst gehts nicht


mfG Krypton

Kleine Fehler in der Schaltung

Von Caro am 16.06.2005 06:11

Erstmal vielen Dank fuer Eure schnelle Hilfe. Hatte nicht so schnell damit gerechnet. Komme auch erst heute dazu, Eure Vorschlaege umzusetzten.
Mir sind allerdings ein paar kleien Fehler aufgefallen, auf die ich ja auch teilweise schon hingewiesen wurde:
- die Verbindung nach Masse ist natuerlich falsch. Habe bisher versaeumt, das auszubessern.
- der verwendete OK ist ein CNY17F nicht 27F.
LG,
Caro

CNY17 zu langsam

Von Anonymous am 16.06.2005 08:56

schau mal ins Datenblatt, eventuell ist dann ein cny17 zu langsam, der hat Turn ON / Off Zeiten von einigen 10uS, was bei deinen Impulslängen vielleicht zu viel sein kann!

Anzeige: