Anzeige:

Schaltung für Schienenreinigungsfahrzeug

Hier finden sie die archivierten Beiträge des alten PHPBB Forums von www.loetstelle.net

Von modellfreund am 04.08.2009 09:07

Hallo, also Ich habe jetzt mal den Plan so umgebaut wie es auf der Platine aufgebaut war. Ich habe den Motor jetzt hinter den Schalter, also mit der Diode zusammen gelötet.

Kann es vielleicht am Reedschalter liegen? Ich habe den Motor, die Gleise und den Reedschalter über einen Stecker mit der Plaine verbunden, und erst als ich den Stecker eingesteckt habe kahm das Problem aufm, also vermute ich das irgendwo da das Problem liegt.

Ich denke das der µC defekt ist weil er halt nicht mehr funktioniert, Ich kann ihn zwar Flashen aber er macht nichts mehr. Ich werde aber im Handbuch mal nachlesen.

Gruß Felix

Von Hotzenplotz am 04.08.2009 18:17

Der Reed-Kontakt ist doch normalerweise ein Schliesser und liegt auch nur auf Masse, kann ich mir also kaum vorstellen, dass der beim Einstöpseln, einen ganzen µC zerschiesst.
Auch durch das Verdrehen des Transistors, sollte der µC keinen Schaden genommen haben.
DU hast den Motor doch fertig gekauft, dann ist dieser auch entstört oder ? Ich glaube das ist bei Komplettsätzen sogar Vorschrift, nagle mich aber icht drauf fest.
Die Diode am Motor ist völlig unnütz, schmeiss die raus.
Teste erst mal ob der µC vernünftg läuft, im Manual ab Seite 19 steht die HV Programmierung. Flash leeren nicht vergessen.
Und schreibe Dir einen simplen Porttester, kann man eh immer brauchen. Lass einfach alle Ports langsam blinken, dass kannst Du ja dann mit den LEDs auf dem STK leicht testen.

Von modellfreund am 05.08.2009 08:41

Hallo,

also der AVR macht nichts mehr.

Gruß Felix

Von Hotzenplotz am 05.08.2009 18:48

Hast Du den denn jetzt im HV mode versucht zu flashen ?
Alles richtig verkabelt ?
Jumper richtig gesetzt ?
AVRStudio auch auf HV gestellt ?



http://img145.imageshack.us/img145/9631/13134103.jpg

Von modellfreund am 05.08.2009 19:16

Hallo, das AVRStudio nutze ich nicht, ich nutze immer Bascom-AVR. Kann ich das denn damit so auch Progrmmieren?

Gruß Felix

Von Hotzenplotz am 05.08.2009 20:47

modellfreund hat folgendes geschrieben:
....das AVRStudio nutze ich nicht.......

Solltest Du aber, allein schon um die Firmware aktuell zu halten.

modellfreund hat folgendes geschrieben:
.....ich nutze immer Bascom-AVR. Kann ich das denn damit so auch Progrmmieren?

Von Bascom habe ich keine Ahnung.

Anzeige: