Anzeige:

Schaltung für Schienenreinigungsfahrzeug

Hier finden sie die archivierten Beiträge des alten PHPBB Forums von www.loetstelle.net

Von modellfreund am 02.08.2009 20:36

Hallo,

also beim Relais handelt es sich um folgendes: http://www.conrad.de/goto.php?artikel=502642 .
Ich habe mal den µC aus der Schaltung genommen und Collector und Emiter verbunden, das Relais hat angezogen, merkwürdig war allerdings, dass das Relais beim entfernen der Drahtbrücke nicht wieder abgefallen ist. Hat vielleicht der Transistor einen weg? Ich habe ein 2N2222A eingebaut, einen anderen habe ich bei CSD-Electronics nicht bekommen. Ich Flashe den µC nicht in der Schaltung sondern nur im STK500, also sollte ich doch dann den Widerstand zwischen R8 und T1 weglassen können oder?

Gru Felix

Von gerold am 02.08.2009 21:55

modellfreund hat folgendes geschrieben:
Widerstand zwischen R8 und T1 weglassen

Hallo Felix!

Ohne diesen Widerstand hast du immer einen undefinierbaren Zustand des Transistors, wenn entweder der µC nicht in der Schaltung ist, oder wenn der µC falsch programmiert wurde. Ich würde deshalb nicht auf diesen Widerstand verzichten. Verdrahte ihn einfach fliegend auf der Platine.

Den Vorwiderstand kannst du bei diesem Relais ohne Probleme auf 1,5 k erhöhen. So sparst du etwas Strom.



Vielleicht hat der Transistor bereits Schaden genommen. Den würde ich vorsorglich tauschen.

Nach dem Umbau mit dem Widerstand:
Wenn du den µC aus der Schaltung nimmst, dann kannst du testen, indem du 5 Volt am IC-Beinchen PB1 anlegst. Das Relais muss schalten.

lg
Gerold
Smile

Von gerold am 02.08.2009 22:07

Hallo Felix!

Dieses kleine Testprogramm, sollte das Relais alle zwei Sekunden umschalten lassen:

Code:
$regfile = "m8def.dat"
$crystal = 1000000
$hwstack = 100
$swstack = 100
$framesize = 100

Relais Alias Portb.1
Config Portb.1 = Output


Do
   Relais = 0
   Wait 2
   Relais = 1
   Wait 2
Loop
End

lg
Gerold
Smile

Von modellfreund am 03.08.2009 11:14

Hallo Gerold,

ich habe jetzt R8 durch ein 1,5kOhm Widerstand ersetzt, R12 eingebaut und den Transistor gewechselt. Das Programm habe ich ebenfals auf den µC gespielt. An der Relaisspule kann man anhand der Spannung messen, dass der µC arbeitet, die Spannung wechslt zwischen 5,4V und 5,9V. Das Relais ziet jetzt garnicht mehr an. Sollte ich vielleicht mal einen anderen Transistortypen einbauen? Ich habe aber nur folgende Typen Zuhause: 2N2222A; BC337-15; BC337-25; BC547B.

Gruß Felix

Von gerold am 03.08.2009 18:19

Hallo Felix!

Wie sicher ist es, dass du den Transistor und die Freilaufdiode richtig eingebaut hast? Ich meine jetzt "wirklich" "richtig" "super" sicher?

lg
Gerold
Smile

Von modellfreund am 03.08.2009 18:39

Hallo Gerold,

ich bin mir ziemlich sicher das der Transistor und die Diode richtig verbaut wurden.

Gruß Felix

Von gerold am 03.08.2009 19:13

modellfreund hat folgendes geschrieben:
sicher das der Transistor und die Diode richtig verbaut wurden

Hallo Felix!

Dann weiß ich nicht weiter. Vielleicht findet jemand einen Fehler im Schaltplan, der dieses Verhalten hervorrufen kann. Ich habe ihn ja als "Draft" gekennzeichnet.

Hier nochmal der Schaltplan:


Wie sieht dein Platinenlayout aus? Hast du auch Fotos vom Aufbau? Fotos, auf denen man dem Verlauf der Leiterbahnen folgen kann. Welchen 2N2222 hast du? Hast du einen Link zum Datenblatt deines Transistors? Wo ist bei deinem Transistor (in eigenen Worten) Kollektor, Basis und Emitter?

lg
Gerold

Von modellfreund am 03.08.2009 20:02

Hallo Gerold,

im Anhang findet sich das Platinenlayout für die Steuerung, ich hoffe das reicht so. Die Schaltung wurde aus Platztechnischen Gründen auf 2 Platinen verteilt. Eine Platine ist für die Stromversorgung und Ladung die andere Platine ist für die Steuerung.

Den Transistor habe ich hier bestellt, ein Datenblatt gibt es leider nicht. Die Bestellnummer lautet: 13500.

Ja... ansonsten habe ich den Transistir so eingebaut wie auf dem Bild zu sehen.

Gruß Felix

Von gerold am 03.08.2009 20:13

modellfreund hat folgendes geschrieben:
Den Transistor habe ich hier bestellt, ein Datenblatt gibt es leider nicht. Die Bestellnummer lautet: 13500.

Hallo Felix!

http://www.alldatasheet.com/datasheet-pdf/pdf/54292/FAIRCHILD/PN2222A.html

Der Transistor steckt verkehrt rum drinnen.

lg
Gerold
Smile

Von modellfreund am 03.08.2009 20:33

Hallo Gerold,

gerold hat folgendes geschrieben:
Der Transistor steckt verkehrt rum drinnen.


tatsächlich, jetzt funktioniert es. Das verwirrt mich, sind die Anschlüsse am Transistor nicht eigentlich so wie auf dem Platinenplan angegeben?

Gruß Felix