Anzeige:

Problem mit Mosfet!

Hier finden sie die archivierten Beiträge des alten PHPBB Forums von www.loetstelle.net

Problem mit Mosfet!

Von Daniel_ am 22.06.2010 21:43

Morgen, Leute!

Also, ich hoffe ich bin hier richtig!
Es geht um das schalten von 240V (Wechselspannung) mit einer Stromquelle von 9 Volt. Ich dachte an Mosfets, hab auch schon ne Schaltung erstellt!
Relais scheiden klar aus, da ich schnelle Raktionzeiten brauche und das in einer großen Häufigeit.

So, nun hat sich folgendes Problem aufgezeigt:
und zwar hab ich das Problem, dass ich etwas brauche, dass ich zwischen GND und "Steuerkreislauf" schalten kann, um zu verhinden, dass ich 240V auf meine 9 Volt Stromquelle bekomme!
Diese Leitung (GND) muss ich ziehen, da sich die Spannung zwischen Souce und Gate entladen muss, da das Mosfet sonst in Kontaktstellung bleibt und der Stromfluss nicht unterbrochen wird!

Ich weis aber nicht wie!

Zur zeichnung:

Sorry, hab auf die schnelle gerade nur eine Paint-Zeichnung gerfertigt!
Der rot markierte Kreis ist die "Problemstelle".

Wichtig ist evt. noch, dass die 240 Volt Wechselspannung sind und die 9Volt Gleichspannung!

Ich hoffe ihr könnt mir weiterhelfen und mein Anliegen konnte ich einigermaßen verständlich rüberbringen!

LG,

Daniel

Re: Problem mit Mosfet!

Von derguteweka am 22.06.2010 22:22

Mahlzeit,

Daniel_ hat folgendes geschrieben:
Also, ich hoffe ich bin hier richtig!
Es geht um das schalten von 240V (Wechselspannung) mit einer Stromquelle von 9 Volt. Ich dachte an Mosfets, hab auch schon ne Schaltung erstellt!
Relais scheiden klar aus, da ich schnelle Raktionzeiten brauche und das in einer großen Häufigeit.

Nimm einen Triac statt den Mosfets.

Daniel_ hat folgendes geschrieben:
So, nun hat sich folgendes Problem aufgezeigt:
und zwar hab ich das Problem, dass ich etwas brauche, dass ich zwischen GND und "Steuerkreislauf" schalten kann, um zu verhinden, dass ich 240V auf meine 9 Volt Stromquelle bekomme!

Dafuer gibts Optokoppler, insbesondere zur Ansteuerung von Triacs gibts Optokoppler mit integrierter Triac-Ansteuerung.
Guck' dir mal so Dinger an, wie den MOC303x, MOC304x - die sind genau fuer sowas gedacht.

Gruss
WK

Von Daniel_ am 22.06.2010 23:13

Dir Triac teile brauchen doch ne spezielle Ansteuerung, oder? Des fällt in meinem Fall aber leider weg! Und Für hohe Spannungen sind die ja auch nicht gerade gedacht!?

Zum Optokoppler:
wie schalte ich den denn rein bzw. hält der überhaupt die spannung aus?
Außerdem glaube ich, dass die Dioden meine Steuerung unmöglich machen, da sie den Strumfluss ja beschränken/nicht möglich machen!

Auf GND muss aber Strom zu meiner steuerung zurückfließen, weil sonst auch kein Strom zum Gate fließt. Wink

Problem is nach wie vor, dass eben keine 240Volt, sondern nur die 9 Volt (mit der auch das Gate angesteuert wird) zurückgehen.
Brauche ich da vielleicht eine Abschrimung oder so etwas in der Art?

Hat möglicherweise jemand ne Idee?
Möglicherweise einfach nen Widerstand, der es auch aushällt, wenn er die 240 Volt abbekommt? Wenn ja was bräuchte ich denn für einen Widerstand? Was sagt ihr dazu?

Also, es darf aber in keinem Fall die 240 Volt ans Steuersignal kommen! Vielleicht noch eine art Sicherung, dass es auch ja nicht passiert..da wäre es auch gut, wenn mir jemand ein Beispiel geben könnte, wie ich es denn dagegen absichern kann!

Vielen Dank schon einmal!#

LG

Von Alv am 23.06.2010 06:11

Du willst eine galvanische Trennung. Die bekommst du nur mit Optokoppler oder Übertrager hin.

Zum Schalten von Wechselspannung eignen sich Triacs am Besten.
Triacs sind extra für hohe Spannungen (min. einige 100V) und hohe Ströme gebaut.

Hier mal eine Prinzipschaltung zur Ansteuerung eines Triacs mit Optokoppler.
Leuchtet die Led, bekommt der Triac keinen Gatestrom und zündet nicht.

Wie schon erwähnt, gibt es spezielle Optokoppler zum Ansteuern von Triacs, die haben dann auch Nulldurchgangsschalter drin.

Von derguteweka am 23.06.2010 07:10

Moin,

Daniel_ hat folgendes geschrieben:
Dir Triac teile brauchen doch ne spezielle Ansteuerung, oder?

Eigentlich ueberhaupt nicht: Fliesst ein ausreichender Triggerstrom durch die G-A1 Strecke, zuendet der Triac, wenn nicht dann nicht. Erst wenn du Phasenanschnittsteuerungen baust, wirds etwas komplexer.

Daniel_ hat folgendes geschrieben:
Des fällt in meinem Fall aber leider weg!

Nur wenn du's nicht reinbaust. Warum hab' ich wohl auf die speziellen Optokoppler verwiesen?

Daniel_ hat folgendes geschrieben:
Und Für hohe Spannungen sind die ja auch nicht gerade gedacht!?

Wie kommste auf das schmale Brett?

Daniel_ hat folgendes geschrieben:
wie schalte ich den denn rein bzw. hält der überhaupt die spannung aus?

Den schaltest du so rein, wie's im Datenblatt steht. Und der haelt genau die Spannung aus, die im Datenblatt steht. Und das Datenblatt gibts im Internet.
Daniel_ hat folgendes geschrieben:
Außerdem glaube ich, dass die Dioden meine Steuerung unmöglich machen, da sie den Strumfluss ja beschränken/nicht möglich machen!

Auf GND muss aber Strom zu meiner steuerung zurückfließen, weil sonst auch kein Strom zum Gate fließt. Wink

Problem is nach wie vor, dass eben keine 240Volt, sondern nur die 9 Volt (mit der auch das Gate angesteuert wird) zurückgehen.
Brauche ich da vielleicht eine Abschrimung oder so etwas in der Art?

Hat möglicherweise jemand ne Idee?
Möglicherweise einfach nen Widerstand, der es auch aushällt, wenn er die 240 Volt abbekommt? Wenn ja was bräuchte ich denn für einen Widerstand? Was sagt ihr dazu?

Ich muss leider sagen, dass ich glaube, dass du ja nicht nur keine Ahnung hast, sondern einen Haufen voelligen Unsinn glaubst und anscheinend nicht in der Lage bist, dir mal ein paar Datenblaetter reinzuziehen.
Das sind aber ganz schlechte Voraussetzungen, wenn man Schaltungen fuer hohe Spannungen / hohe Stroeme bauen will.

Daniel_ hat folgendes geschrieben:
Also, es darf aber in keinem Fall die 240 Volt ans Steuersignal kommen! Vielleicht noch eine art Sicherung, dass es auch ja nicht passiert..da wäre es auch gut, wenn mir jemand ein Beispiel geben könnte, wie ich es denn dagegen absichern kann!

Glaubst du, du bist der erste Mensch mit diesem Problem? Lies die Datenblaetter.
Aber so wie ich das seh', bist du da leicht ueberfordert. Und das ist noch freundlich ausgedrueckt. Deshalb solltest du nicht mit Netzspannung arbeiten. Weil du das sicher nicht einsehen willst: Es gibt schon fertig aufgebaute Triacs incl. der ganzen Ansteuerelektronik; sowas heisst : Solid State Relais und sowas gibts z.b. beim Reichelt. Das machts dir evtl. leichter.

Aber schaff dir erstmal ein bisschen Wissen an. So ne geballte Ladung Unsinn hab' ich schon lang nicht mehr an einem Stueck gelesen.

Bau nicht die Schaltung von Alv nach, denn die ist auch grosser Humbug.

Gruss
WK

Re: Problem mit Mosfet!

Von Daniel_ am 23.06.2010 12:40

derguteweka hat folgendes geschrieben:
Mahlzeit,

Daniel_ hat folgendes geschrieben:
Also, ich hoffe ich bin hier richtig!
Es geht um das schalten von 240V (Wechselspannung) mit einer Stromquelle von 9 Volt. Ich dachte an Mosfets, hab auch schon ne Schaltung erstellt!
Relais scheiden klar aus, da ich schnelle Raktionzeiten brauche und das in einer großen Häufigeit.

Nimm einen Triac statt den Mosfets.

Daniel_ hat folgendes geschrieben:
So, nun hat sich folgendes Problem aufgezeigt:
und zwar hab ich das Problem, dass ich etwas brauche, dass ich zwischen GND und "Steuerkreislauf" schalten kann, um zu verhinden, dass ich 240V auf meine 9 Volt Stromquelle bekomme!

Dafuer gibts Optokoppler, insbesondere zur Ansteuerung von Triacs gibts Optokoppler mit integrierter Triac-Ansteuerung.
Guck' dir mal so Dinger an, wie den MOC303x, MOC304x - die sind genau fuer sowas gedacht.

Gruss
WK


okay, ich muss zugeben, dass ich mich mit Optokoplern, Triacs und relais noch nicht beschäftigt habe! Ich befasse mich eher mit IC´s und mikrocontrollern, wie den 74HCT 66 oder 53ern...

aber ich glaube, ich werde nen fertiges solid state relais benutzen!
Brauche ich denn dann den Optokoppler noch?

ich würde gerne dieses: http://www.reichelt.de/?SID=20SCUCTKwQARQAADkNIA8e5a8e0b9265b9386f54ce6d7b1d31c9f;ACTION=3;LA=2;GROUP=C38;GROUPID=3298;ARTICLE=15439;START=0;SORT=artnr;OFFSET=1000 benutzen!

Muss ich denn davor noch einen Optokoppler schalten und wenn ja, wie gehe ich des an? Ich les mich gerdae in die Materie ein, aber bin leider noch nicht so weit!

Wäre schön, wenn ihr mir helft!

LG

Re: Problem mit Mosfet!

Von Alv am 23.06.2010 13:31

Daniel_ hat folgendes geschrieben:

ich würde gerne dieses: http://www.reichelt.de/?SID=20SCUCTKwQARQAADkNIA8e5a8e0b9265b9386f54ce6d7b1d31c9f;ACTION=3;LA=2;GROUP=C38;GROUPID=3298;ARTICLE=15439;START=0;SORT=artnr;OFFSET=1000 benutzen!

Muss ich denn davor noch einen Optokoppler schalten


Der hat den Optokoppler bereits eingebaut. Ansteuern wie eine Leuchtdiode.

Re: Problem mit Mosfet!

Von Daniel_ am 23.06.2010 13:37

Alv hat folgendes geschrieben:
Daniel_ hat folgendes geschrieben:

ich würde gerne dieses: http://www.reichelt.de/?SID=20SCUCTKwQARQAADkNIA8e5a8e0b9265b9386f54ce6d7b1d31c9f;ACTION=3;LA=2;GROUP=C38;GROUPID=3298;ARTICLE=15439;START=0;SORT=artnr;OFFSET=1000 benutzen!

Muss ich denn davor noch einen Optokoppler schalten


Der hat den Optokoppler bereits eingebaut. Ansteuern wie eine Leuchtdiode.


also einfach an die steuerleitung?
muss evt. nochn widerstand davor geschaltet werden?

lg

Re: Problem mit Mosfet!

Von Alv am 23.06.2010 16:26

Daniel_ hat folgendes geschrieben:

also einfach an die steuerleitung?
muss evt. nochn widerstand davor geschaltet werden?


Im Zweifelsfall das Datenblatt befragen. Bei meinem flüchtigen Blick sieht es aus, als ob der Eigang nur eine Leuchtdiode ist, also bei 9V Steuerspannung unbedingt einen passenden Vorwiderstand benutzen.

Re: Problem mit Mosfet!

Von Daniel_ am 23.06.2010 19:32

Alv hat folgendes geschrieben:
Daniel_ hat folgendes geschrieben:

also einfach an die steuerleitung?
muss evt. nochn widerstand davor geschaltet werden?


Im Zweifelsfall das Datenblatt befragen. Bei meinem flüchtigen Blick sieht es aus, als ob der Eigang nur eine Leuchtdiode ist, also bei 9V Steuerspannung unbedingt einen passenden Vorwiderstand benutzen.


470 Ohm sollten passen oder?

lg

Anzeige: