Anzeige:

Strommessung über Shunt-Widerstand

Hier finden sie die archivierten Beiträge des alten PHPBB Forums von www.loetstelle.net

Strommessung über Shunt-Widerstand

Von modellfreund am 02.04.2011 18:18

Hallo,

ich möchte mit einem Atmega8 den Strom eines Motors überwachen und auf einem LCD ausgeben. Dazu habe ich den Motor, wie unten zu sehen, angeschlossen.
Nun mein Problem: Wenn ich den Motor z.B. im Leerlauf betreibe, misst der ADC-Eingang einen Wert von 30-100. Die Strommessung muss aber ziemlich genau werden, weil der Motor bei einem bestimmten Strom abschalten soll.

Wie kann ich diesen großen Messunterschied der einzelnen Messungen aufheben?

Gruß Felix

Von BellaD am 02.04.2011 18:36

moin

1.Den Motor entstören !
2.Tiefpassfilter (Widerstand,Kondensator) in die Ltg. zum AD
3.Mittelwertbildung der gemessenen Werte
4.Softwarefilter ,mehrere Möglichkeiten

mfg

Von Sam am 02.04.2011 18:36

Am besten machst du 10 oder mehr Messungen und bildest den Mittelwert.
Hast du auch an die Induktivität am ADC gedacht?

Von modellfreund am 02.04.2011 18:52

Ja ich habe an die Spule gedacht. Einen Kondensator parallel zum Shunt-Widerstand zu klemmen bringt nichts. Aber vielleicht sollte man einen kleinen Elko parallel zum Motor klemmen.?

Von BellaD am 02.04.2011 19:13

so ...das wäre die einfache Version
Die Freilaufdiode muss den Motorstrom abkönnen !
Wieviel Strom zieht der Motor denn unter Last ?
evtl so nahe wie möglich am Motor einen Stützkondensator
und die Masse Sternförmig an einem Punk zusammenführen,der Motorstrom darf nicht über die masse des analogteils fliessen !

Von BellaD am 04.04.2011 22:50

moin

gehts nun, oder nicht ?
wäre ja mal interessant zu wissen ob sich jetzt änderungen im verhalten zeigen oder der ADC Eingang schon geschrottet ist Wink
Man kann auch bei kleinen Motoren mit bis zu 70V Induktionsspannung rechnen ,also am besten noch ne Z diode an den ADC Eingang

Von modellfreund am 06.04.2011 20:06

Hallo,

also, der Motor zieht ca. 3A. Die Schaltung habe ich heute meinem Bekannten gegeben, für den das Problem besteht. Sobald ich weiß ob es funktioniert oder nicht gebe ich bescheid.

LG Felix

Von modellfreund am 13.05.2011 17:47

So,

habe ich glatt vergessen. Embarassed

Die Schaltung funktioniert. Sie liefert zwar keinen 100%igen glatten Wert ist aber völlig ausreichend.

Vielen Dank!

Gruß Felix

Anzeige: