Anzeige:

AVR ATMEGA16

Hier finden sie die archivierten Beiträge des alten PHPBB Forums von www.loetstelle.net

AVR ATMEGA16

Von Dana am 18.06.2011 03:30

Hallo Zusammen,
brauche dringend Hilfe!
Wer kann mir in Dortmund bei Implementierung einem Bascom-Programm in ein ATMEGA16 persönlich helfen? Das Bascom-Funktions-Programm ist schon geschrieben, das Testgerät ist gebaut und ein AVR-Programmierer ist vorhanden. Nette Hilfe wird natürlich vergütet.
Grüße
Dana

Von BellaD am 18.06.2011 09:59

moin


Zitat:
Wer kann mir in Dortmund bei Implementierung einem Bascom-Programm in ein ATMEGA16 persönlich helfen? Das Bascom-Funktions-Programm ist schon geschrieben, das Testgerät ist gebaut und ein AVR-Programmierer ist vorhanden.


Wo liegt das Problem ?

mfg

Fusebits??

Von Dana am 18.06.2011 15:38

Hi,
das Problem liegt (glaube ich) an Fusebit-Einstellungen, besonders die die Taktfrequenz bezogen sind. Ich habe alle mögliche Einstellungen versucht, erfolglos.
Da ich absolut neuling bin, möchte gerne neben Fehlerbehebung auch ein bischen dazu lernen.
Grüße
Dana

Von Hotzenplotz am 19.06.2011 10:35

Mal ehrlich, was genau erwartest Du, wenn sich wirklich jemand finden sollte, der sich dazu bereit erklaert ? Einige hundert Stunden Unterricht, oder bist Du einfach nur einsam ?

Drucke Dir erst mal das Datenblatt aus und beschaeftige Dich damit.

http://www.atmel.com/atmel/acrobat/doc2466.pdf

Und danach liest Du das....

http://www.mikrocontroller.net/articles/AVR_Fuses

http://www.engbedded.com/fusecalc/

.....dann klappt es auch mit den Fuse - Settings. So kompliziert ist das naemlich garnicht. Nur wenn man einfach rumklickt und ausprobiert bis es evtl. mal laeuft, kann man nichts lernen. Von wegen "Ich vermute das es daran liegt"

Programmiere ein Lauflicht oder einen LED-Blinker und spiele mit dem Takt rum, dann "siehst" Du auch noch was passiert.

Und wenn Du Dein Programm anhaengen wuerdest, koennte man Dir auch mit den Settings helfen.

Anzeige: