Anzeige:

WD TV Live tot

Hier finden sie die archivierten Beiträge des alten PHPBB Forums von www.loetstelle.net

WD TV Live tot

Von Alv am 01.10.2013 21:04

Hi

Ich habe ein defektes (?) WD TV Live bekommen. Leider ist die Fernbedienung nicht dabei.

Beim Einstecken des Netzteils passiert rein gar nichts, keine Led, kein Bild...
Drücken des Resettasters, egal wie lange, oder Spannung anlegen bei gedrücktem Resettaster bringt auch nichts.

Im Internet konnte ich dazu nichts finden, bei fehlerhaftem Flash soll zumindest noch das WD-Logo erscheinen...

Im Gerät habe ich 3V, die Knopfzelle ist auch ok.
Aber schon der 5V-Spannungswandler für USB wird nicht eingeschaltet.

Ich habe das Gerät mal über Nacht am Netzteil gelassen, am nächsten Morgen waren alle Bauteile auf der Platine immer noch eiskalt...?

Kennt jemand das WD TV oder hat Ideen, was man weiter probieren könnte?

Re: WD TV Live tot

Von derguteweka am 02.10.2013 20:35

Moin,

Alv hat folgendes geschrieben:
Im Gerät habe ich 3V, die Knopfzelle ist auch ok.
Aber schon der 5V-Spannungswandler für USB wird nicht eingeschaltet.


Ich hab' keine Ahnung, was da fuer ein Decoder/Prozessor Chip drinnen verbaut ist, aber ueblicherweise brauchen die noch diverse andere Spannungen, um zu laufen. z.B.
1..3 verschiedene Corespannungen im Bereich 0.9..1.2V
1 Spannung fuer das SDRAM, vielleicht 1.5 oder 1.8V
1..3 verschiedene IO-Spannungen im Bereich 1.8 bis 3.3V

Die werden normalerweise irgendwo auf der Hauptplatine mit kleinen Schaltwandlern erzeugt. Manche Chips wollen die verschiedenen Spannungen dann sogar in einer festgelegten Reihenfolge beim An- und Abschalten sehen...

Gruss
WK

Re: WD TV Live tot

Von Alv am 04.10.2013 09:50

Der Hauptprozessor ist ein Sigma SMP8670AD, BGA, also nichts zu messen.

Das Stechernetzteil liefert 12V. Der große Spannungswandler für USB (5V) wird nicht eingeschaltet.
Ein möglicher zweiter Spannungswandler (mit 10-Pin-IC BF790) bekommt überhaupt keine Spannung.
Ein Analog-Regler erzeugt aus den 12V 3,3V, diese geht zusammem mit der Knopfzelle und versorgt einen µC (Weltrend WT69P3).
Der Resettaster hat an beiden Pins keine Spannung.

Der IR-Empfänger wird mit 3V versorgt und scheint zu funktionieren.

Das WDTV eines Bekannten startet (LED, Eternet-Leds, Bild) sobald das Netzteil eingesteckt wird.
Es gibt alledings verschiedene WDTV deren Unterschiede ich nicht kenne.

Gibt es da vielleicht Versionen, die erst durch Betätigen der Fernbedienung eine Reaktion zeigen?

Re: WD TV Live tot

Von derguteweka am 04.10.2013 11:20

Moin,

Alv hat folgendes geschrieben:
Der Hauptprozessor ist ein Sigma SMP8670AD, BGA, also nichts zu messen.

Naja, die Corespannung wird ueblicherweise irgendwo nebendrann erzeugt und dann auf einer Zwischenlage im PCB an die Balls gebracht. Muss man halt gucken, wo da Spannungen erzeugt werden.
Alv hat folgendes geschrieben:
Das Stechernetzteil liefert 12V. Der große Spannungswandler für USB (5V) wird nicht eingeschaltet.

Wenn der SMPxx oder der WTxx den nicht einschalten, weil sie selber nicht alle Spannungen kriegen...

Alv hat folgendes geschrieben:
Ein möglicher zweiter Spannungswandler (mit 10-Pin-IC BF790) bekommt überhaupt keine Spannung.
Ein Analog-Regler erzeugt aus den 12V 3,3V, diese geht zusammem mit der Knopfzelle und versorgt einen µC (Weltrend WT69P3).
Der Resettaster hat an beiden Pins keine Spannung.

Wenn 3.3V aus 12V mittels Analogregler erzeugt werden, dann ist das nur fuer gaaaanz kleine Stroeme sinnvoll. Also z.b. fuer eine µControllerversorgung, fuer einen kleinen µC, der das Powermanagement fuer die ganze Kiste uebernimmt. Und dann ggf. andere Spannungswandler fuer den Hauptprozessor zuschaltet.

Alv hat folgendes geschrieben:
Der IR-Empfänger wird mit 3V versorgt und scheint zu funktionieren.

Das WDTV eines Bekannten startet (LED, Eternet-Leds, Bild) sobald das Netzteil eingesteckt wird.
Es gibt alledings verschiedene WDTV deren Unterschiede ich nicht kenne.

Gibt es da vielleicht Versionen, die erst durch Betätigen der Fernbedienung eine Reaktion zeigen?


Ich hab' keine Ahnung von den WDTV Dingern. Aber mach' doch mal ein einigermassen scharfes und genuegend aufgeloestes Photo vom PCB, wo man die Bauteile erkennen kann. Im www hab' ich gelesen, dass da auch ein Ethernet-Phy von Realtek verbaut ist - der wird fuer die Ethernet-LEDs zustaendig sein und haengt ueblicherweise auch an einer 2.5-3.3V IO-Spannung und einer niedrigeren Corespannung - manchmal haben solche Phys auch Analogregler im Chip integriert, manchmal auch mit externem Regeltransistor. Da sollen also Spannungen messbar sein...

Gruss
WK

Re: WD TV Live tot

Von Alv am 04.10.2013 14:16

Anbei die Bilder.

Ich habe jetzt auch mal an den Quartzen gemessen. Keiner schwingt!

Der WT (U1) wird ständig mit 3V versorgt, entweder über Analogregler Q6 oder über die Knopfzelle. Der IR-Empfänger P1 geht auch an U1.
Ich habe den Verdacht, daß U1 den Rest des Boards einschaltet (soll). Allerdings schwingt sein Quartz X4 auch nicht...

Re: WD TV Live tot

Von derguteweka am 04.10.2013 14:48

Moin,

Alv hat folgendes geschrieben:
Ich habe den Verdacht, daß U1 den Rest des Boards einschaltet (soll).

Den hab' ich auch. In der dbox2 war das aehnlich geloest; da gab's einen kleinen Hilfsprozessor, der die Tasten, IR-Empfaenger und Power gemanaged hat und bei Bedarf dann den Hauptprozessor starten konnte.

Alv hat folgendes geschrieben:
Allerdings schwingt sein Quartz X4 auch nicht...

Ganz sicher? Das wird ja ein 32.768Khz Uhrenquarz sein, mutmasse ich mal. Und der Oszillator ist auf minimale Stromaufnahme getrimmt, d.h. sowie du da auch nur mit der Pruefspitze eines Scopes dran gehst, kanns gut sein, dass der Oszillator nicht mehr schwingt, weil der Tastkopf auch mit 1-10MOhm und ein paar pF zu "niederohmig" ist. Haeng' mal eine kleine Spule an den Tastkopf und geh' nur in die Naehe des Quarzes und guck' ob du irgendwie ein paar mV Schwingung auffangen kannst.

Ansonsten siehts eher schlecht aus. Kannst ja gucken, ob du die Schaltwandler-ICs (Die Chips in der Naehe der 4R7 und 2R2 Speicherdrosseln und wahrscheinlich auch noch der 8-fuesser neben der bedrahteten Drossel) im www findest, ob die Enable-Eingaenge haben und ob die auf "disable" stehen. Vielleicht auch noch ein paar Infos zu dem kleinen Prozessor...

Gruss
WK

Anzeige: